Access to REST API on server with self signed cert


#1

I am trying to connect to a dev server APIs and receiving an error due to non-verified cert. Is there a way to over-ride the cert validation when setting up data plugin details? I am attaching a screen shot from another thread that shows an overirde in the data plugin set up screen, however this does not come up in my version (1.7).

From the Controlling the Web Service thread:

From my React Studio app (Version 1.7.0 (362))

Error message when trying to load data: The certificate for this server is invalid. You might be connecting to a server that is pretending to be “192.###.#.###” which could put your confidential information at risk.

How can I override the cert validation in order to do some dev testing against this environment? Thanks for insight that can be provided.


#2

Hi,

The settings are available but you need to scroll the plugin settings panel a bit. It’s definitely a UI bug and we will change the background color or something to make it more obvious that settings window is scrollable.

If you still have problems when connecting to service you can edit the plugin code yourself. Just open Plugins->Plugin manager and edit the plugin code.


#3

Thanks, I have found I need to click to the far left of the pane to then be able and scroll down to see the last two config items. Setting the Allow Insecure HTTP option resolved the issue and I now get a response from the API. Thanks for your help!