Disable Auto-Sign In Not Working

Is anyone having any issues with the login gate not responding to the auto sign in check box? If I uncheck it, it still results in an auto-sign in. Screen Shot 2020-11-11 at 9.52.31 AM