How to maintain paragraph spacing within data sheets?


#1

Hi everyone,

I was wondering if anyone knew how to maintain paragraph spacing for text that’s within lists (data sheets)?

When I paste the text into the Data Sheet’s “selected cell” (text content) section, it shows the paragraph spacing. But upon compiling the app the paragraph spacing doesn’t show up on the app screen. It just shows up as one single block of text.

It doesn’t seem like there is anywhere in the JS file where I can add, for eg, HTML
to manually fix this.

I’m sure there’s other ways to fix this, but my knowledge might be limited. Any help to fix this paragraph spacing issue would be deeply appreciated.

:slight_smile:


#2

I believe you can enable html content for text fields in the ‘Element’ tab in the right panel, should allow you to do this


#3

Hi apetta,

Thank you for your suggestion.

I selected the ‘Allow HTML content’ check box, however, the result was still the same when I exported the app. Please refer to the screen shot below:

The data is not connected to an API. It is just text that I have entered into the data sheet, as you can see in Screenshot 2.


#4

This is the text entered into the selected cell with the correct paragraph spacing:
13%20AM


#5

This is the Elements screen with the ‘Allow HTML content’ checkbox selected, and both the component and preview are showing the correct paragraph spacing:

(Could only post one image, as I am a new user)

Thanks anyway!


#6

Ahh, you’ll have to give it html content and not just text. e.g.

This is a
paragraph with

some breaks in it.

<p> This is a <br> paragraph with <br><br> some breaks in it.<p>