The certificate for this server is not valid

I was configuring a Google Spreadsheet as a datasource and I got this message:

Am I doing something wrong?

Hi, sorry for the inconvenience the certificate was expired. Try now again.

1 Like